Comments on: Install Warcraft 3 on Ubuntu Linux – A Visual Guide http://tipsfor.us/2009/06/04/install-warcraft-3-on-ubuntu-linux-a-visual-guide/ Tech Tips, Reviews, Tutorials, Occasional Rants Sat, 31 Aug 2013 15:50:35 +0000 hourly 1 https://wordpress.org/?v=4.8 By: fair man http://tipsfor.us/2009/06/04/install-warcraft-3-on-ubuntu-linux-a-visual-guide/#comment-13075 Sun, 11 Dec 2011 18:53:24 +0000 http://www.tipsfor.us/?p=2227#comment-13075 How about making a simple Warcraft III compilation for linux?
What’s so different between it and Warcraft for Mac when the system base is the same?

Game industry need to understand the need of making a Linux release to get more buyers, more income.

]]>
By: Crimshaw http://tipsfor.us/2009/06/04/install-warcraft-3-on-ubuntu-linux-a-visual-guide/#comment-9537 Sun, 03 Jul 2011 15:25:36 +0000 http://www.tipsfor.us/?p=2227#comment-9537 Oh, forgot to mention something. I’m using Ubuntu 11.04 Natty Narwhal and when I start I have those 2 bars at the top and bottom, because I prefer the Ubuntu Classic. There is no longer a tab in Prefrences>Appearances to disable effects. On the login screen I tried switching my Ubuntu version selector thing (lol) to Ubuntu Classic (No Effects), but even this doesn’t help. I still have those dumb bars. The game is still playable, it’s just annoying with the bars.

Just letting everyone know.

]]>
By: Crimshaw http://tipsfor.us/2009/06/04/install-warcraft-3-on-ubuntu-linux-a-visual-guide/#comment-9536 Sun, 03 Jul 2011 15:18:31 +0000 http://www.tipsfor.us/?p=2227#comment-9536 Ekalb, just select your video card driver in “Additional Drivers”.

Just stopping by to let everyone who sees this know, that I was going to install this through PlayOnLinux yesterday, but the site where you need to download something for it to install correctly was no longer up. So, the installation on PlayOnLinux no longer works I think.

Great guide though. Really helpful.

]]>
By: Ekalb http://tipsfor.us/2009/06/04/install-warcraft-3-on-ubuntu-linux-a-visual-guide/#comment-8514 Sun, 17 Apr 2011 00:29:06 +0000 http://www.tipsfor.us/?p=2227#comment-8514 Hello, I followed this tutorial down to the smallest detail (or so I believe) and I can get Warcraft III to launch, not with a launcher though. The launcher thing doesn’t bug me so much, what bugs me is that when I launch Warcraft III it comes up with the home screen thing, you know, the tower, but there are no textures. Like, the tower in the back is just pure white with some shading, and everything is discolored and it lags so bad that I thought I’d have to do a hard shutdown just to get out of there.

I just want to know what the problem is. Did I not do something right?

Help is much appreciated.

]]>
By: RuinedMortal http://tipsfor.us/2009/06/04/install-warcraft-3-on-ubuntu-linux-a-visual-guide/#comment-8216 Sun, 06 Mar 2011 07:25:36 +0000 http://www.tipsfor.us/?p=2227#comment-8216 Edit: Found the issue with the rendering. I now have about 2 SPF (seconds per frame -.-)
I am using -opengl and -window

]]>
By: RuinedMortal http://tipsfor.us/2009/06/04/install-warcraft-3-on-ubuntu-linux-a-visual-guide/#comment-8215 Sun, 06 Mar 2011 07:21:43 +0000 http://www.tipsfor.us/?p=2227#comment-8215 Disregard, I figured out the install problem. I now have it working with the patch, but the rendering of the graphics is a complete disaster. Halp!!

]]>
By: RuinedMortal http://tipsfor.us/2009/06/04/install-warcraft-3-on-ubuntu-linux-a-visual-guide/#comment-8203 Sat, 05 Mar 2011 08:50:08 +0000 http://www.tipsfor.us/?p=2227#comment-8203 Hey,
Following the tut quite nicely, until I got to the installation of War3TFT. I used the wine commands again and it comes up with this error: ‘wine: Bad EXE format for Z:\media\Warcraft_iii\install.exe’.
I don’t know why it is looking in the z:\ dir because I installed it into the c:\
Email me back please.

–RuinedMortal

]]>
By: Daniel http://tipsfor.us/2009/06/04/install-warcraft-3-on-ubuntu-linux-a-visual-guide/#comment-7957 Wed, 02 Feb 2011 21:53:37 +0000 http://www.tipsfor.us/?p=2227#comment-7957 I just have one question about wine, whenever I try to run an .exe I get this:

The file ‘/media/Warcraft III/install.exe’ is not marked as executable. If this was downloaded or copied from an untrusted source, it may be dangerous to run. For more details, read about the executable bit.

So I goto properties, and permission and mark as an executable, but on a cd I have to copy everything over to a folder or something then do this step. Is there anyway to no have to do that, to just have Ubuntu recognize it and run it in wine?

I can still get it to work, but this is just an annoying problem! Again thanks for the tutorial!

Dan

]]>
By: Wrath http://tipsfor.us/2009/06/04/install-warcraft-3-on-ubuntu-linux-a-visual-guide/#comment-7797 Fri, 14 Jan 2011 17:50:50 +0000 http://www.tipsfor.us/?p=2227#comment-7797 Hi, I tried this guide and it worked out fine, except for when I got to the part about actually installing the game, i attempt to open the install.exe but it says Blocked: wine start /unix, and says that it isn’t marked as executable. Any help?

]]>
By: Ironmon http://tipsfor.us/2009/06/04/install-warcraft-3-on-ubuntu-linux-a-visual-guide/#comment-7782 Thu, 13 Jan 2011 02:32:00 +0000 http://www.tipsfor.us/?p=2227#comment-7782 Umm…. I installed it perfectly and I have no lag or sound error, but I can not find any explanation why I can not see other people on my LAN or them see me. I have already tried about 6 methods and am now wondering if it is literally my networking. But I am still wondering how to let it accept Warcraft now.

]]>