Comments on: The Most Important Firefox Plugins You Will Ever Need. (A Series.) http://tipsfor.us/2008/04/11/the-most-important-firefox-plugins-you-will-ever-need-a-series/ Tech Tips, Reviews, Tutorials, Occasional Rants Sat, 31 Aug 2013 15:50:35 +0000 hourly 1 https://wordpress.org/?v=4.8 By: J Wong http://tipsfor.us/2008/04/11/the-most-important-firefox-plugins-you-will-ever-need-a-series/#comment-4841 Thu, 01 Jan 2009 02:00:07 +0000 http://www.tipsfor.us/2008/04/11/the-most-important-firefox-plugins-you-will-ever-need-a-series/#comment-4841 I try to install the noscript 1.8, but I am told it is incompatible with the latest Firefox 3.0.5

Do you know when it will be updated, to work with latest Firefox and Vista?

regards

]]>